# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=where)(.*?)((ORDER BY|GROUP BY|HAVING|LIMIT|OFFSET|$).*)"
test_str = ("select \"DIM_1\".\"col1\",\n"
"\"DIM_2\".\"col2\" ,\n"
"\"DIM_3\".\"col3\" , \n"
"\"DIM_4\".\"col4\" , \n"
"\"FAT_1\".\"col5\" \n"
"from \"FAT_1\",\n"
" \"DIM_1\",\n"
" \"DIM_2\",\n"
" \"DIM_3\",\n"
" \"DIM_4\"\n"
"where \"DIM_1\".\"col1\" IS NOT NULL \n"
"AND \"DIM_2\".\"col2\" LIKE ('SUCCESS')\n"
"AND \"DIM_3\".\"col3\" BETWEEN 20161213 AND 20161222\n"
"AND \"DIM_4\".\"col4\" > 0\n"
"LIMIT 10")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.