#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(?<=where)(.*?)((ORDER BY|GROUP BY|HAVING|LIMIT|OFFSET|$).*)"
Local $sString = "select "DIM_1"."col1"," & @CRLF & _
""DIM_2"."col2" ," & @CRLF & _
""DIM_3"."col3" , " & @CRLF & _
""DIM_4"."col4" , " & @CRLF & _
""FAT_1"."col5" " & @CRLF & _
"from "FAT_1"," & @CRLF & _
" "DIM_1"," & @CRLF & _
" "DIM_2"," & @CRLF & _
" "DIM_3"," & @CRLF & _
" "DIM_4"" & @CRLF & _
"where "DIM_1"."col1" IS NOT NULL " & @CRLF & _
"AND "DIM_2"."col2" LIKE ('SUCCESS')" & @CRLF & _
"AND "DIM_3"."col3" BETWEEN 20161213 AND 20161222" & @CRLF & _
"AND "DIM_4"."col4" > 0" & @CRLF & _
"OFFSET 10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")