re = /(?!.*?--)(^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)/m
str = 'john--doe@x--x.c--om
john-doe@x-x.c-om'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end