$re = '/\b(?<!!)\w+/';
$str = '!x play search words here
!x p search words here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);