const regex = /^(?:2[0-5]|[1][0-9]|[1-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:2[0-5]|[1][0-9]|[1-9])$', 'gm')
const str = `0
1
2
3
9
10
15
25
26`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}