const regex = /\[(?!(.*\].*with)).*with.*\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?!(.*\\].*with)).*with.*\\]', 'g')
const str = `a<b CaO–FeO–MgO–Al<sub>2</sub>O<sub>3</sub>–SiO<sub>2</sub>–H<sub>2</sub>O`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}