package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Mar(cos|tín)`)
var str = `Marcos
Martín
Mauricio`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}