$re = '/:\d+:\K.*?(?=:\d+|$)/m';
$str = ': :1:1st message:2:2nd message:x:this is where it fails status: fail :3:3rd message';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);