use strict;
my $str = 'This seems to work, but I have obviously fudged many things and wonder if anyone has a better idea. (It has to allow for html at any point, and a lot of other quirks from users\' writing. rawr. moo moo . rawr!
I am not too concerned about people gaming the system - there are still manual checks, this is just a first-stage check to lighten the load.) My other main concern is efficiency - I\'m new to regex and don\'t know what is a \'normal\' calculation time, but the debugger(s) I\'m using are struggling at times when I paste in a block of text to check, and I don\'t know if this is caused by my RegEx or the debugger. It is often timing out on longer sections of text where there is no match. Is there a more efficient way to do what I\'m wanting?';
my $regex = qr/^(\s*(\S+\s+){3}([.?!]\s*)?([^\s.?!]+\s+)*\S+\s*[.?!]){7,}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}