$re = '/^(?=.*\d)(?=.*[A-Z])(?=.*[!@#$%^&*? ]).{8,}$/i';
$str = 'AAAA2@AAAA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);