package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(.*?[^\\"])"`)
var str = `"/sample/path/directory" "/sample/path/directory/tmp\" tmp" 172.28.128.5 -alldirs -mapall=501:20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}