re = /(^|\s)([^*\s])/m
str = ' *these are my words '
subst = '\\1+\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result