$re = '/\s?\(.*?\)\s?/m';
$str = 'This is a (simple) text (or an example text). Thank you!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);