re = /(?:[\d]{1,3})\.(?:[\d]{1,3})\.(?:[\d]{1,3})\.(?:[\d]{1,3})/m
str = 'hddhkc 192.168.1.1 gfjfhfv
174.45.1.1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end