$re = '/\]\s\[|\]\s(?=\w)|^\[/';
$str = '[date] [thread] [loglevel] [class] some text describing the event that happened.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;