$re = '/\b[0-9]{2}([0-9]{2})-\1-\1\b/';
$str = '2008-08-08
2009-09-09
2009-09-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);