const regex = /(\d*)
\.?\s?
([^,]+)
,\s
([^\d]+)
\s?
(\d+)
\s
(
(?:[A-Z]{3})?
)
\s?
(
# OLD SOLUTION
# (?:
# (?!\d\:\d)
# .
# )*
# NEW SOLUTION
.*?
)
\s?
(
(?:\d+:)?
\d+\.\d+
)
(?:
\s
(\d+)
)?
$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)
\\.?\\s?
([^,]+)
,\\s
([^\\d]+)
\\s?
(\\d+)
\\s
(
(?:[A-Z]{3})?
)
\\s?
(
# OLD SOLUTION
# (?:
# (?!\\d\\:\\d)
# .
# )*
# NEW SOLUTION
.*?
)
\\s?
(
(?:\\d+:)?
\\d+\\.\\d+
)
(?:
\\s
(\\d+)
)?
$', 'mgi')
const str = `12. NUNEZ CHENG, Walter 74 Club Tennis Las Terr 3:44.57 123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}