$re = '/^(?!.*[iIoOqQ])[a-zA-Z0-9]+$/m';
$str = 'test
tist
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);