re = /art(?:(?!art-)[\s\S])*code:"XXX"(?:(?!art-)[\s\S])*art-/m
str = 'begin
more text
art
id:213213
code:"XXX"
name:234
art-
art
id:543
name:72
code:"AAA"
art-
art
code:"XXX"
id:32
name:46
art-
art
code:"CCC"
id:8765
art-
art
id:876
code:"DDD"
art-
even more text
even more text
end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end