const regex = /<div class="search tooltip box-video" search="(.*)" title="(.*)">(.*)<a href="(.*)"><img src="(.*)" class="capa-poster" \/><\/a><\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="search tooltip box-video" search="(.*)" title="(.*)">(.*)<a href="(.*)"><img src="(.*)" class="capa-poster" \\\/><\\\/a><\\\/div>', '')
const str = `<div class="search tooltip box-video" search="revenge" title="Revenge">
<a href="revenge.html"><img src="http://i.imgur.com/1leadWY.jpg" class="capa-poster" /></a></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}