#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(8|\+7)\d{10}$"
Local $sString = "+79261364557" & @CRLF & _
"89261364557" & @CRLF & _
"9261364557" & @CRLF & _
"926136455" & @CRLF & _
"892613645577" & @CRLF & _
"+792613645577" & @CRLF & _
"+89261364557"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")