re = /^(\d+\/\d+\/\d+ \d+:\d+:\d+)\s+\S+\s+\S+\s+(.+), client/m
str = '2019/03/15 14:22:59 [error] 14064#0: <error I need to find>, client: XXX.XXX.XXX.XXX, server: example.com, request: "POST /hello", host: "example.com"
2019/03/15 14:22:59 [error] 14064#0: <error I need to find>, client: XXX.XXX.XXX.XXX, server: example.com, request: "POST /hello", host: "example.com"
2019/03/15 14:22:59 [error] 14064#0: <error I need to find>, client: XXX.XXX.XXX.XXX, server: example.com, request: "POST /hello", host: "example.com"2019/03/15 14:22:59'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end