package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w+\.?(\w+\b)?`)
var str = `hello
hello.
hello.cc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}