$re = '/[P][Z][N][:]["]([0-9]+)["]/';
$str = 'aaaPZN:"123"56bbbb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);