package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([0-9]+[a-zA-Z]+)|([a-zA-Z]+[0-9]+))([a-zA-Z0-9]*)`)
var str = `test@3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}