re = /((?:[^@"]+|"[^"]*")@[^;]+)(?:;|$)/m
str = '"one@tw;,.\'o"@hotmail.com;"some;thing"@example.com;hello@world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end