$re = '/(?:<div class=\'ClassName\'>)(?:\s*)([\S\s]*)(?:<\/div>)/m';
$str = '<div class=\'ClassName\'>
foo
<div>
bar
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);