re = /"Status":("?)(?<cstatus>.*?)("?),.*?"ProblemFlag":("?)(?<probflag>.*?)("?),.*?"IncreasePending":("?)(?<increasePend>.*?)("?),.*?"SafePay":("?)(?<safepay>.*?)("?),"PastDue":("?)(?<pastdue>.*?)("?),"LastPmtAmt":("?)(?<lastpayamt>.*?)("?),"NextPmtAmt":("?)(?<nextpayamt>.*?)("?),"LastPayDate":("?)(?<lastpaydate>.*?)("?),"NextDebitDate":("?)(?<nextdbtdate>.*?)("?),"AddendumDate":("?)(?<addendmdate>.*?)("?)}/m
str = '{"Status":"AP","ProblemFlag":"0","IncreasePending":"1","SafePay":"1","PastDue":"0","LastPmtAmt":"0.00","NextPmtAmt":"453.00","LastPayDate":"","NextDebitDate":"2021-02-28 00:00:00","AddendumDate":"2021-02-15 00:00:00"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end