$re = '/.*\/([a-z]*)\/.*\/.*/';
$str = 'http://www.insight-post.tw/team-project/brexit/20160713/15654';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);