$re = '/^0?(\d{1,2}):/m';
$str = '
19:00:00
08:00:00
12:30:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);