$re = '/([A-Z]\w+(?: [A-Z]\w*)*).*?(\d{1,2}/\d{1,2}/\d{2})/m';
$str = 'John Smith has a birthday of 2/29/90';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;