re = /(?<=\)[.;])\s*([^()]+\((?:19|20)\d\d\))/
str = 'Прп. Моисея Мурина (ок. 400). Обре́тение мощей прп. Иова Почаевского (1659). Собор преподобных отцов Киево-Печерских, в Дальних пещерах (прп. Феодосия) почивающих. Прп. Саввы Крыпецкого, Псковского (1495). Прав. Анны пророчицы, дщери Фануилевой, встретившей Господа Иисуса Христа в храме Иерусалимском (I). Мц. Шушаники, кн. Ранской (V) (Груз.). Сщмч. Алексия Будрина (1918); прмчч. Казанских: Сергия Зайцева, Лаврентия Никитина, Серафима Кузьмина, Феодосия Александрова, Леонтия Карягина, Стефана, Георгия Тимофеева, Илариона Правдина, Иоанна Сретенского и Сергия Галина (1918). Прп. Исаакия Оптинского (1894). Сщмч. Александра Медведева диакона (1918); сщмч. Николая Георгиевского пресвитера (1931); сщмч. Василия Сокольского пресвитера (1937). Грузинской иконы Божией Матери (1650).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end