package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*?[A-Z])(.*?[a-z])(.*?[0-9])(.*?[#?!@$%^&]).{8}$`)
var str = `123123213
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}