# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\b
\+?1?
(?<separator>\s|-|\.)?
(?: # area code with optional parentheses
(?<area_code>[2-9][0-8]\d)
|\((?&area_code)\)
)
(?&separator)?
(?: # exchange
(?!555)
[2-9]
(?!11)\d\d
)
(?&separator)?
\d{4} # line
\b
"""
test_str = ("212 718-1234\n"
"(212)718-1234\n"
"(212) 718-1234\n"
"1(212)718-1234\n"
"1-212-718-1234\n"
"1.212.718.1234\n"
"+1-212-718-1234\n"
"+1.212.718.1234\n"
"1-212-718-1234\n"
"+1 (212) 718-1234\n\n"
"# 1-VALID 2-VALID 4-VALID\n"
"231 212 1234\n\n"
"234-235-5678 is a valid telephone number with area code 234, central office prefix (exchange) 235, and line number 5678. \n\n"
"12127181234\n"
"(212)7181234\n\n\n"
"# 1-INVALID 2-INVALID 4-INVALID\n"
"091 012 1234\n"
"# 1-INVALID 2-VALID 4-INVALID\n"
"081 012 1234\n"
"171 012 1234\n"
"# 1-VALID 2-VALID 4-INVALID\n"
"231 012 1234\n"
"# 1-INVALID 2-INVALID 4-VALID\n"
"091 212 1234\n"
"# 1-INVALID 2-VALID 4-VALID\n"
"081 212 1234\n"
"171 212 1234\n"
"231 555 1234\n\n"
"867-5309 missing area code\n\n"
"The number 234-911-5678 is invalid, because the central office code must not be in the form N11. 314-159-2653 is invalid, because the office code must not begin with 1. 123-234-5678 is invalid, because the NPA must not begin with 0 or 1.\n\n"
"1 212) 718 1234\n\n"
"121271812341212718123412127181234")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.