// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(19|20)\d{2}[- :][VW](?:[0-4][0-9]|5[0-2])").unwrap();
let string = "2016-W25
1980-V52";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}