$re = '/\bsia\b/';
$str = 'Questa regex ricerca la parola sia in una frase: ma siamo sicuri che sia corretta?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);