package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){GUILD(?:.+)?}`)
var str = `{GUILD_PREFIX} {ANY}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}