re = /.*&(.*?)=.*/
str = 'http://mytestdomain.com/temp-param-page-2/?wpv_paged_preload_reach=1&wpv_view_count=1&wpv_post_id=720960&wpv_post_search&wpv-women-clothing[]=coats'
# Print the match result
str.match(re) do |match|
puts match.to_s
end