#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[0-9])(?!\S)"
Local $sString = "1.1.1.1 kaseroi 1.1.1.1 jsoiu 1.1.1.1 " & @CRLF & _
" 1" & @CRLF & _
" 1" & @CRLF & _
" 11" & @CRLF & _
" 123" & @CRLF & _
" 132132.23213.213213.123213" & @CRLF & _
"23.23.23.23 2321321.33.3.3.3 3.3..3.3.3.3.3. " & @CRLF & _
" 3.3.3.3.3.3" & @CRLF & _
"3.3.3.3" & @CRLF & _
"34.5.6.7" & @CRLF & _
" agdi 123213.44.4.5 12.12.12.12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")