$re = '/[ ](?=[ ])|[^-_,A-Za-z0-9 ]+/m';
$str = '[one@ !two three-four]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;