re = /^(\d{3})\.?(\d{3})\.?(\d{3})\-?(\d{2}$)$|^(\d{2})\.?(\d{3})\.?(\d{3})\/?([0-1]{4})\-?(\d{2})$/
str = '07634269111179'
# Print the match result
str.match(re) do |match|
puts match.to_s
end