package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:([Gg][Ii][Rr] 0[Aa]{2})|((([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Ha-hJ-Yj-y][0-9]{1,2})|(([AZa-z][0-9][A-Za-z])|([A-Za-z][A-Ha-hJ-Yj-y][0-9]?[A-Za-z])))) [0-9][A-Za-z]{2}))\b`)
var str = `1A noplace road, random city, NR1 2PK, UK
1A noplace road, random city, NZ1 2PK, UK`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}