$re = '/(?:\G(?!^)|\bpassport\b).*?\b([a-zA-Z]{0,2}\d{6,12}[a-zA-Z]{0,2})\b/';
$str = 'my friends passport numbers are V123456, V123457 and V123458';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);