$re = '/\w*bc\w*\.\d*/';
$str = '{name:{abc.12, abcdef, bc1454}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);