$re = '/(?s)<a\s*href=[\'"](?<link>.+?)[\'"]\s*>(?<text>.+)<\/a>/m';
$str = '<a href="https://blogs.technet.microsoft.com/exchange/2011/04/21/mixed-ing-it-up-multipartmixed-messages-and-you/">More reading
material</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);