$re = '/(<=|<|>=|>|(?<=[^a-zA-Z])or(?=[^a-zA-Z]))/m';
$str = '<=,das<asdorsds1324or1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);