package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^\.]+\.log).*`)
var str = `/path/to/logs/Device_01.log*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}