re = /^[0-9A-F]{8}-[0-9A-F]{4}-[0-9A-F]{4}-[0-9A-F]{4}-[0-9A-F]{12}$/i
str = 'D0111E97-A01D-4123-BDE6-632496FF33D6'
# Print the match result
str.match(re) do |match|
puts match.to_s
end