$re = '/^(?=.{3,10}$)([a-z\d_.-]*)[a-z](?1)$
/m';
$str = '123my_45
12345g789
_.-_.-_.-
my_dog.hasfleas
my_doG.has
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);