$re = '/\b[a-zA-Z]+\b|\b[0-9]+\b/m';
$str = 'Hello 123 55 afghanistan123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);